node.js를 사용할 때 npm 호환성이나 node.js 안정성 등의 문제로 여러 버전의 node.js를 사용해야 할 때가 있다.

요즘은 이런 문제를 해결하기 위한 툴이 다른 프로그래밍 언어들에도 있다.

좀 문제는 대부분 linux만 지원하고 windows는 지원하지 않는 경우가 많다.


node.js의 nodist는 windows에서 사용할 수 있어서 windows에서 node.js를 사용하는 경우 이 툴로 설치 하기를 추천한다.


공식 주소. https://github.com/marcelklehr/nodist


컴퓨터에 여러 버전의 node.js를 설치하고, 선택할 수 있다.


특정 디렉토리만 특정 버전의 node.js를 사용하는 것도 가능하다.


만약 이미 node.js가 설치 되어 있다면 먼저 제거 하고 설치한다.



사용 법

- 설치 가능한 버전 보기: nodist dist

- 사용 하고 싶은 버전 설치하기: nodist + v4.3.0

- 임의의 버전 선택 사용하기: nodist 4.3.0 

- 특정 디렉토리만 특정 버전 사용하기: nodist local 4.3.0

저작자 표시
신고
by 흥배 2016.10.28 08:00
| 1 |

티스토리 툴바